nixos-config/system/home-manager/terminal.nix
Christoph Heiss 1299db6708
home-manager: terminal: foot: lock terminal title
Signed-off-by: Christoph Heiss <christoph@c8h4.io>
2024-04-20 00:31:57 +02:00

55 lines
1.5 KiB
Nix

{ config, lib, ... }:
let
cfg = config.my.terminal;
mkFontDesc = size: weight:
"Jetbrains Mono:size=${
toString size
}:weight=${weight},Noto Color Emoji:size=${toString size}";
in {
options.my.terminal.fontSize = lib.mkOption {
default = 9;
type = lib.types.numbers.positive;
};
config.programs.foot = {
enable = true;
settings = {
main = {
shell = "tmux";
font = mkFontDesc cfg.fontSize "semibold";
font-bold = mkFontDesc cfg.fontSize "extrabold";
locked-title = true;
};
scrollback.lines = 0;
cursor = {
style = "underline";
underline-thickness = 2;
};
mouse.hide-when-typing = "yes";
# Based on https://github.com/sonph/onehalf
colors = {
alpha = 0.96;
foreground = "383a42";
background = "fafafa";
regular0 = "383a42"; # black
regular1 = "e45649"; # red
regular2 = "50a14f"; # green
regular3 = "c18401"; # yellow
regular4 = "0184bc"; # blue
regular5 = "a626a4"; # magenta
regular6 = "0997b3"; # cyan
regular7 = "fafafa"; # white
bright0 = "383a42"; # bright black
bright1 = "e45649"; # bright red
bright2 = "50a14f"; # bright green
bright3 = "c18401"; # bright yellow
bright4 = "0184bc"; # bright blue
bright5 = "a626a4"; # bright magenta
bright6 = "0997b3"; # bright cyan
bright7 = "fafafa"; # bright white
};
};
};
}