nixos-config/services/openssh.nix
Christoph Heiss dfeffdf041
All checks were successful
flake / build (push) Successful in 3m9s
services: openssh: disable sftp subsystem for real
Apparently, the default value is `true`, not `false` as I erroneously
assumed. :/

Fixes: 389f345 ("services: openssh: disable sftp subsystem")
Signed-off-by: Christoph Heiss <christoph@c8h4.io>
2024-08-24 17:39:21 +02:00

15 lines
297 B
Nix

{
services.openssh = {
enable = true;
allowSFTP = false;
settings = {
KbdInteractiveAuthentication = false;
PasswordAuthentication = false;
PermitEmptyPasswords = false;
PermitRootLogin = "no";
UseDns = false;
X11Forwarding = false;
};
};
}