nixos-config/common/packages.nix
2024-05-21 13:04:01 +02:00

36 lines
642 B
Nix

{ config, pkgs, ... }:
{
hardware.enableRedistributableFirmware = true;
environment.systemPackages = (with pkgs; [
dmidecode
ethtool
gnugrep
iputils
lm_sensors
lshw
lsof
nettools
pciutils
powertop
python3
smartmontools
strace
tcpdump
usbutils
which
xz
zstd
]) ++ (with config.boot.kernelPackages; [ cpupower perf ]);
programs.command-not-found.enable = false;
programs.htop.enable = true;
programs.iotop.enable = true;
programs.mtr.enable = true;
programs.traceroute.enable = true;
programs.zsh.enable = true;
security.apparmor.enable = false;
}